Vulnerabilidad en el kernel de Linux 2.6.x – 2.6.24.1

Hola:

Gracias a Kriptopolis me entero de una vulnerabilidad que afecta al Kernel de GNU/LiNU, en sus versiones 2.6.x – 2.6.24.1.

Esta vulnerabilidad local se puede clasificar como muy grave.

Cualquier usuario con acceso local puede ejecutar un sencillo exploit que le permita obtener privilegios de root.

Podéis descargaros el código fuente del exploit desde aquí.

También existe otra variante del exploit, aquí.

Tan solo tendréis que compilarlo y ejecutarlo como usuario normal.

Para compilar el exploit:

:~$ gcc exploit.c -o exploit

Para ejecutar el exploit:

: ~$ ./exploit

Os dejo una captura de pantalla de Kriptopolis:

Como veis sencillo y eficaz 😉

Ya ha salido un parche que soluciona el problema. Podéis descargarlo de aquí.

Ya existe una nueva versión del Kernel con la vulnerabilidad ya resuelta, aquí.

Fuente: http://www.kriptopolis.org/
Más información: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464953 

Un saludo.

Publicado en Noticias

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: